Monday, April 13, 2009

Trouble With Vista (by Eddie)

As anyone visiting this blog knows, I'm pretty much using Animate exclusively now - both for animation and design - and things have been going pretty good.

However, having just bought a new laptop I've realized what a lot of others - including Lili - have known for a while now; Animate and Vista do not work well together. The main problem is painting. No matter how small a fill area is, the spinning wheel will come up whenever you try to paint. Same thing happens when you try to modify a color. What should have been some very simple character designs to fill, took me ALL DAY because of the Animate/Vista incompatability.

So what is to be done? I believe Toon Boom's answer is along the lines of 'we haven't tested this to run with Vista'. But how does that help PC users? New PCs run on Vista these days. Is anyone at Toon Boom searching for a solution? And PLEASE don't tell me to go and buy a Mac....


  1. I wouldn't tell you to buy a Mac, but you could ditch Vista and install Windows XP.

    Yeah, it's not the best solution, but it seems to be the end-all for frustrated Vista users these days.

  2. yes, I could do that but...

    I shouldn't have to! Surely it is up to Toon Boom to make sure their software is conpatible with the newest operating systems? Hmmmmm?

    Plus, I actually like Vista and the features on my new laptop. Is it TOO much to ask that animation software works with the lastest OS? Does Flash have these problems with Vista? Come on Toon Boom!

  3. I wish I could, but I can't ditch Vista. I have too much work on this computer and I don't have the time to start from scratch. :(

  4. And you shouldn't have to! As I said: is it too much to ask for animation software to keep up with the latest OS?

  5. i’m not so familiar with windows but maybe you run a second partition on your harddisk with windows XP and animate?
    not very comfortable, of course but at least you could do your painting ...

    (and yeah, you should go and buy a mac, haha)

  6. I've heard lots of programs have Vista compatibility issues, and lots of users are not even considering the upgrade from XP. A few have even downgraded new computers that came with Vista, so they can continue to use the software they like. Probably a second partition is the best temporary alternative until the time Toon Boom fixes those issues, as they should. It's probably going to happen soon, so you can work full time with Vista.

    I have never seen so much rejection for a specific OS, not even with Windows ME, which was probably the worse Microsof published. Lots of small software suppliers did not develop Vista versions until very recently...

  7. Simple solution for you'z vista users out their.
    1. "Buy" or get this soft "VMware Workstation", or something like so.(It's an operating system emulator)

    2. Install it, and install windows Xp in it.

    3. Now install Toon Boom Animate within The xp, that's running in the OS emulator. That's the only work-around right now.

  8. Mortal Arts - Assuming you are on Windows Vista, is this what you are doing? And it works?

  9. i think the problem is vista,its very unstable,animate there are no the unique program that dont work well in vista, and the programers of software are not sure if the invest of adapting to vista its worth, couse windows are still finishing and patching the sistem, windows is the only software i think that dont pay beta testers, the beta testers are us!using a software that is not finished well,i had a lap with vista and the best solution i had is install the xp version and work very well all the programs

  10. This comment has been removed by the author.

  11. This comment has been removed by the author.

  12. After a lot of frustration, in the end tis be the best solution for me. I got VMware Workstation for a great deal "cough" "cough". Since I already own a win Xp. I just install it, in it. Now everything works like a brand new car. I'm sure they are cheap and free virtual machines out their you can download. I haven't try this method but it has worked for others.
    "First, It looks like you might be able to eliminate the problem by turning off the “Aero” feature of Vista.
    According to a forum post, it says to disable the “desktop compositing” (cancel AERO mode)."

    The problem lies within the OpenGL, Vista has a problem with it. Oh well I hope everything works for yeah. Am looking forward to see more tuts and advice from you'z! :D

  13. Hi, I'm using Animate on Vista here in the UK and have non of the problems you have mentioned. I'm not using a laptop, I have a PC workstation. Maybe it's not a compatibility issue at all between Animate and Vista but something to do with your laptop.
    I'm an animator thouh, not a computer expert :)
    Try running Animate with Vista on another machine and see what happens.
    As I said though, no problems filling or changing swatches with Animate on Vista over here.

    Good luck,

  14. Hi Mark - I am using Vista 64 bit on a PC workstation (HP to be exact), not a laptop and this problem is effecting me too. The program runs painfully slow when drawing with the BRUSH TOOL and when PAINTING/FILLING. If I draw slowly with the brush tool there isn't an issue. If I draw fast (as you do with rough sketches), I get the spinning Vista circle in between every 3rd or so stroke. It's very annoying.

    In "Animation mode" though, everything is fine. Painting is the main issue. What PC do you use? And just to check - are you on Vista or Vista 64-bit? I wonder if it's a 64-bit thing...

  15. I was having a LOT of trouble running animate on Vista, and I'm sure it's microsofts hampering of OpenGl on Vista. (They want to control the way 3d is displayed / used / licensed on the platform so that developers can only use Direct X 10, 11.. etc.)

    However, there may have been some changes in policy with the Windows 7 release candidate I'm using. Animate is MUCH better on Windows 7. (I'm running a 64 bit copy of windows 7 too)

    I hate to say install a new OS, but you should go for a total system reinstall and try upgrading to windows 7! Works for me, and all the bad buggy slowness of Vista is gone in 7!

    Alternately, you can try installing this beta of opengl for Vista. (I'm about to try it in 7 and see if it speeds things up even further)

    Good luck!
    Great blog.

  16. Ah, also in Vista, try right clicking the icon, and go to properties / compatibility. Check compatibility mode for XP, and turn off desktop composition and run as an administrator.. that too might help!

  17. Hi cartoonmonkey,
    This is great news about Windows 7!
    RE: VISTA, I have tried everything ... I have updated my NVIDIA driver and I have also checked the compatability mode for XP. No difference, unfortunately :(

  18. Plausible solutions:
    1.Go to TB animate-> Preference->OpenGL-> play with the settings to see if anything works.
    2.Uninstall and reinstall TB Animate
    3.Update Graphics card/Update Vista-> Service pack 2
    4.Check if your card has OpenGL 2.0 or higher
    5.Create a dual-boot of xp/vista or Ms7/Vista
    If all fails go back to flash cs4

  19. Flash CS4? Ugh - NEVER!

    I'd rather put up with a little paint-filling lag, than go back to that unsupported pain-in-arse

  20. hey, my feedreader is always empty ... you not talking anymore?
    too busy?


  21. i mean new blog entries ...
    it’s always nice to read what you do and i learned a lot.